Unable to save SpectroSERVER datatabase as the ./SSdbsave utility errors out
search cancel

Unable to save SpectroSERVER datatabase as the ./SSdbsave utility errors out

book

Article ID: 45110

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Unable to save SpectroSERVER datatabase as the ./SSdbsave utility errors out

Database already locked by: specadmin, {Install user}
By process: c:\win32app\Spectrum\SS-Tools\SSdbsave.exe,
By process ID: <process number>
On network node: <node name>
Which started at: <date and time>
SPC-DBS-20095: c:\win32app\Spectrum\SS-Tools\SSdbsave.exe Error: Unable to open database

Environment

Release: 20.2 / 21.2
Component: SpectroSERVER

Cause


The SpectroSERVER is in running state and has a lock on the database.

Resolution

Step 1- Stop the SpectroSERVER:

  1. You could stop the SpectroSERVER from:
  2. (a) SPECTRUM Control Panel (SCP) console
  3. (b) from the BASH Shell
  4. Method (a): via SCP:
  5. Launch the SCP:
  6. In the Process Control group, click Stop SpectroSERVER
  7. The message, "Are you sure you want to shutdown the SpectroSERVER?" appears.
  8. Click OK.

 NOTE: Shutting down the SpectroSERVER can take a few minutes.

  1. Verify that the SpectroSERVER status is INACTIVE.
  2. Method (b): From Command Line Interface:

 NOTE: Unlike from SCP, the below procedure will stop not only the SpectroSERVER but also the Archive Manager processes.

 NOTE: On Linux and Solaris, the script should not be run as the root user.

  1. Log onto the SpectroSERVER system
  2. If on Windows, launch the BASH shell via command prompt. To do so, open command prompt and type the below commands:
  3. bash -login
  4. cd $SPECROOT/bin
  5. ./stopSS.pl

Step 2- Run the SSdbsave utility from $SPECROOT/SS directory:

  1. From the same bash shell as above, navigate to the $SPECROOT/SS directory and use the SSdbsave utility to perform the full backup as below:
  2. cd $SPECROOT/SS
  3. ../SS-Tools/SSdbsave.exe -cm <backupname>

NOTE: To perform models only backup run the command "../SS-Tools/SSdbsave.exe -m <backupname>"

NOTE: To perform catalog only backup run the command "../SS-Tools/SSdbsave.exe -c <backupname>"

Step 3- Verify the database is created and saved

  1. To do so run the command "ls" and verify the backupname with .SSdb extension created.

NOTE: If you have stopped the SpectroSERVER from SCP, start the SpectroSERVER from SCP as well. To do so, in the Process Control group, click Start SpectroSERVER

NOTE: If you have stopped the SpectroSERVER from the BASH Shell, run the below commands to start it

  1. cd $SPECROOT/bin
  2. ./startSS.pl to start the SpectroSERVER and Archive Manager processes.

Additional Information

Please reference the "SSdbsave" section of the documentation for more information.