The client vCenter logs located at /var/log/vmware/vsan-health/vmware-vsan-health-service.* contain the following error message:
xxxx-xx-xxTxx:xx:xx.xxxZ ERROR vsan-mgmt 32208 [vc@4413 tid="58885" func="ServiceAccountHelper::_convertFault" opID="e4397372"] Receive fault about operating service accountTraceback (most recent call last): File "bora/vsan/xvc/lib/ServiceAccountHelper.py", line 62, in _convertFault File "bora/vsan/xvc/lib/ServiceAccountHelper.py", line 240, in ResetServiceAccountPassword File "/usr/lib/vmidentity/svcaccountmgmt/python-bindings/com/vmware/vcenter/svcaccountmgmt_client.py", line 407, in reset File "/usr/lib/vmware-vpx/vsan-health/vapi/vapi_runtime-2.100.0.egg/vmware/vapi/bindings/stub.py", line 408, in _invoke File "/usr/lib/vmware-vpx/vsan-health/vapi/vapi_runtime-2.100.0.egg/vmware/vapi/bindings/stub.py", line 357, in native_invokecom.vmware.vapi.std.errors_client.NotFound: {messages : [LocalizableMessage(id='com.vmware.vcenter.svcaccountmgmt.notfound', default_message='Service account not found for given name (Service account not found:
Note that all of the following conditions in the "Environment" section and the symptoms above including the error in the vmware-vsan-health-service logs must be met to confirm this issue
The issue is resolved in vCenter Server 9.1.1
Workaround:
To workaround this issue, the service account password can be reset manually by executing a script located at the client vCenter Server.
root./usr/lib/vmware-vpx/vsan-health/bin./ServiceAccountCtl.sh -r -h '[server vcenter IP]' -u '[email protected]' -p '[server vcenter password]'./ServiceAccountCtl.sh -v -h '[server vcenter IP]'./ServiceAccountCtl.sh -r -v -h '[server vcenter IP]' -u '[email protected]' -p '[server vcenter password]'Note: Replace [email protected] with your local SSO admin user if the local SSO domain is different.