Automic Automation ILM Fails to Start - Troubleshooting
search cancel

Automic Automation ILM Fails to Start - Troubleshooting

book

Article ID: 451068

calendar_today

Updated On:

Products

Automic Automation

Issue/Introduction

This article advises on scenarios where the Information Lifecycle Management (ILM) process fails to start in Automic Automation. If standard service restarts do not resolve the issue, adjusting alignment may be needed in the database. This troubleshooting applies to Automic Automation environments on Oracle databases.

Environment

  • Automic Automation Engine (all supported versions)
  • Database: Oracle

Cause

Once ILM experiences a failure, it typically writes the reason/failure to the log file. The initial cause of the failure/error should be resolved - typically requiring a DBA. Subsequent attempts to start ILM should not fail with the same error. 

Resolution

If clearing the initial error reported in the Automic log files doesn't help to successfully start the ILM service, perform the following steps:

  1. Collect Logs: Gather the Automic logs
  2. Collect DB Exports: Capture the following database query results:
    1. SELECT * FROM ISTMT;
    2. SELECT * FROM IDS WHERE IDS_NAME IN ('AH','MELD','XAO','IPH');
    3. SELECT * FROM iph ORDER BY IPH_Idnr DESC;
    4. SELECT OVW_VValue, OVW_Value1 FROM ovw, oh WHERE OH_Idnr = OVW_OH_Idnr AND oh_name = 'UC_ILM_SETTINGS';
    5. SELECT OVW_VValue, OVW_Value1 FROM ovw, oh WHERE OH_Idnr = OVW_OH_Idnr AND oh_name = 'UC_ILM_CONTAINER_MISC';
    6. SELECT OVW_VValue, OVW_Value1 FROM ovw, oh WHERE OH_Idnr = OVW_OH_Idnr AND oh_name = 'UC_ILM_CONTAINER_REPORTS';
    7. SELECT OVW_VValue, OVW_Value1 FROM ovw, oh WHERE OH_Idnr = OVW_OH_Idnr AND oh_name = 'UC_ILM_CONTAINER_STATISTICS';
  3. Open a support case. 
  4. Upload the gathered Logs and Exports to support.