VCF upgrade precheck fails with VCFMS-HEALTH-002 errors due to incorrect vCenter folder placement
search cancel

VCF upgrade precheck fails with VCFMS-HEALTH-002 errors due to incorrect vCenter folder placement

book

Article ID: 450997

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

During a VMware Cloud Foundation (VCF) upgrade precheck, the process fails and halts with platform health check errors. The platform resources remain in an InProgress state because the VCF auto node cannot be deployed.

The following specific VCFMS-HEALTH-002 errors display in the precheck results:

Platform Health Check Error [platform-package-core : 1 of 1 resources are not ok: vmsp-platform: wrong resource state: InProgress - package deployment is in progress;] [VCFMS-HEALTH-002]
Platform Health Check Error [platform-control-plane-core : 1 of 1 resources are not ok: vcf-mgmt-xxx: wrong resource state: InProgress - Rolling 3 replicas with outdated spec (1 replicas up to date);] [VCFMS-HEALTH-002]
Platform Health Check Error [platform-machines-core : 1 of 4 resources are not ok: vcf-mgmt-yyy: wrong resource state: InProgress - 1 of 2 completed;] [VCFMS-HEALTH-002]

Where vcf-mgmt in: vcf-mgmt-xxx is the VCFA runtime prefix

When checking the machine state in the vmsp-platform namespace using 

kubeclt -n vmsp-platform get machines 

There are two machines that pop up in the error message, then when checking the both machine status we can find the info about 

kubectl get machine vcf-mgmt-xxx -n vmsp-platform -o yaml

kubectl get machine vcf-mgmt-yyy -n vmsp-platform -o yaml


This command returned an error message "Unable to find template by name /xxxx/vm/vcf-services-platfrom-template-9.0.2.0.25067117", confirming that the VCF auto node was stuck in the deploy stage and could not be provisioned, because 
template is not located in the correct vCenter Server folder as defined by the vmsp-platform specification.

Environment

VMware Cloud Foundation (VCF)
VCFA 9.x

Cause

The legacy VCFA virtual machine and the VCF-Services-platform template are not located in the correct vCenter Server folder required by the vmsp-platform specification. This folder mismatch prevents the VCF runtime control plane from cloning the template to deploy the second VCF auto node, leaving the resources stuck in an InProgress state and causing the precheck to fail.

Resolution

To resolve this issue, you must align the vCenter folder structure with the platform specification:

  1. Move the legacy VCFA node into the correct vCenter folder as defined in the vmsp-platform specification.

  2. Move the VCF-Services-platform template to the correct vCenter folder.

  3. Move the affected node machines into the correct vCenter folder.

  4. Wait for VCF to automatically redeploy the nodes.

  5. Once the nodes successfully redeploy, rerun the upgrade precheck.