In DSM-install\logs\TRC_AMRSS.log on scalability server, the administrator sometimes can see errors:Debug.cpp |000160|ERROR | delivery errorDebug.cpp |000160|ERROR | start Recived VERIFY_SIG with filesize 0
At the same time, the agent TRC log in DSM-install\logs folder has errors
A-Engine |amLog | |000000|ERROR | cCollectSoftwareDetected::ProcessIntellisigSw only Create/Modify is supported for Intellisig detected definitionsA-Engine |amLog | |000000|ERROR | cCollectSoftwareDetected::ConvertSignatureList2Struct skipping, error processing intellisig for Ruuid:<uuid>|description:<description>|ca_dsm_detection_method:intellisig|ca_dsm_parent_type:product|ca_dsm_isig_version:2.6|ca_dsm_record_type:release|ca_dsm_swdef_versionnumber:0.20.29.0|ca_dsm_release_name:aimgr (64-bit)|ca_dsm_release_version:0.20.29.0|product_category:APPX Applications|ca_dsm_product_name:aimgr (64-bit)|ca_dsm_product_version:0.20|software_creator_uuid:<uuid>|ca_dsm_swdef_name:aimgr (64-bit)|ca_dsm_swdef_version:0.20.29.0|
This article explains that these errors are actually info type messages that the administrator can ignore.
APPX application is not present on the agent machine when scan happens.
The AM Agent executed an IntelliSig scan and detected that the APPX application "aimgr 64-bit) 0.20.29.0 is no longer present on the machine. Therefore, a line like this is generated in the AM Software inventory file:
Ruuid:<uuid>|description:<description>|ca_dsm_detection_method:intellisig|ca_dsm_parent_type:product|ca_dsm_isig_version:2.6|ca_dsm_record_type:release|ca_dsm_swdef_versionnumber:0.20.29.0|ca_dsm_release_name:aimgr (64-bit)|ca_dsm_release_version:0.20.29.0|product_category:APPX Applications|ca_dsm_product_name:aimgr (64-bit)|ca_dsm_product_version:0.20|software_creator_uuid:<uuid>|ca_dsm_swdef_name:aimgr (64-bit)|ca_dsm_swdef_version:0.20.29.0|First character R means removes.
When the Engine collects this line, it logs this message:
cCollectSoftwareDetected::ProcessIntellisigSw only Create/Modify is supported for Intellisig detected definitionsThis occurs because the Engine cannot delete the Intellisig signature from the database. Only Insert/Update could be done by the Engine.
The reason is the intellisig signature may be linked to other agents. Deleting the signature will delete the intellisig inventory on all agents.
In other words, these are info type messages not really errors so the administrator can ignore them.