Invalid value: "hostPath": hostPath volumes are not allowed to be used when trying to set up SiteMinder 12.9 in containers
search cancel

Invalid value: "hostPath": hostPath volumes are not allowed to be used when trying to set up SiteMinder 12.9 in containers

book

Article ID: 450835

calendar_today

Updated On:

Products

SITEMINDER

Issue/Introduction

Trying to deploy SiteMinder 12.9.0 in Containers, the following error is obtained and the deployment fails

Invalid value: "hostPath": hostPath volumes are not allowed to be used

Cause

That may happen because of a syntax error in the config-retriever configuration

configuration:
 repository: <repository name>
 image: config-retriever
 tag: <SM version>
 enabled: truetype: "gdi"
 aws:
region: ""
keyID: ""
accessKey: ""
 
In this example, gdi is wrong and should be git instead

Resolution

Correct the wrong value and retry