Data Collector intermittently is unable to connect to Data Aggregator
search cancel

Data Collector intermittently is unable to connect to Data Aggregator

book

Article ID: 45079

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Data Collector or Data Aggregator are unavailable.

 

Environment

Performance Management 2.7+

Cause

The first step to take is to check in on the logs on the specific device.  For example on the Data Aggregator you would check the /opt/IMDataCollector/apache-karaf-2.4.3/karaf.log and you may find this line:

 

ERROR | Manager-thread-4 | 2016-07-19 14:38:07,006 | shutdown | ces.shutdown.ShutdownManagerImpl  131 | ommon.core.services.impl |       | Shutting down the data aggregator.It was detected that no data repository nodes were contactable. The uncontactable hosts are:[HOSTNAME]

 

The above error tells you that the Data Repository is down and with the Data Repository down, the Data Aggregator cannot function.  This same pattern also holds true for the Data Collector but the log you check is the /opt/IMDataCollector/apache-karaf-2.4.3/shutdown.log:

 

2016-05-31 16:00:30,762 | WARN  | roxyReg-thread-1 | shutdown | om.ca.im.osgishell.BundleManager  139 | 190 - com.ca.im.data-collection-manager.osgishell - 2.7.0.RELEASE-167 |  | Unable to connect to the Data Aggregator at host <HOSTNAME>. Shutting  down the Data Collector. This may take up to 10 minutes.

 

This error tells you that the Data Aggregator is down or you are unable to connect to it.  Both of these errors will show if the Data Repository falls as the services are dependent on each other and will cascade down.

Resolution

You must make sure that the Data Repository is online and functioning then that the Data Aggregator is online and functioning before you can have Data Collectors or NetOps Portal up and running.