Virtual machines are unable to ping their default gateway as the reply packets are dropped on the ESXi hypervisor.
search cancel

Virtual machines are unable to ping their default gateway as the reply packets are dropped on the ESXi hypervisor.

book

Article ID: 450784

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Virtual machines on an ESXI hypervisor are unable to ping their default gateway. The packets originating from the VMs are seen leaving the host uplink (VMNIC) but the reply packets are not.

Environment

VMware vSphere ESXi

Cause

Return packets are arriving on an unexpected uplink. The TeamVSReverseFilterPerList IOChain drops a packet if it is received on a switch port (vNIC) over an unmapped uplink (VMNIC) - meaning an uplink that is not assigned to that port. This asymmetry occurred because the physical switch was configured with a port-channel, whereas the ESXi uplinks were not bundled.

Resolution

Ensure that reply packets are received on the correct uplink. In this specific case, the reply packets returned on a different uplink than the one used to send the outbound traffic. Since the packets were received on a switchport via the incorrect uplink, they were dropped by the TeamVSReverseFilterPerList IOChain of the receiving switchport: