VCF Installer Brownfield Import Fails at Stage "Join the existing operations appliance", subtask 6 of 9 completed
search cancel

VCF Installer Brownfield Import Fails at Stage "Join the existing operations appliance", subtask 6 of 9 completed

book

Article ID: 450778

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • The issue prevents the successful addition of a Cloud Proxy to an existing VCF Operations deployment during a brownfield import.
  • UI symptoms:
    • On the VCF Installer UI a red banner error is observed:

An error occurred in task "Prepare input for adding Cloud Proxy to existing VCF Operations deployment". See Tasks panel to learn more.

    • On the Tasks panel this is observed:

Subtask: Prepare input for adding Cloud Proxy to existing VCF Operations deployment. Input preparation for adding VCF Cloud Proxy node to existing VCF Operations has failed Reference Token: ####

Milestone: Join the existing operations appliance

Description: Prepare input for adding Cloud Proxy to existing VCF Operations deployment

Status: Failed

    • The output of running https://<vcf_operations_fqdn>/casa/node/status returns an address of vcf_operations_IP, where an address of <vcf_operations_fqdn> is expected
    • VCF Operations UI > Build > Lifecycle > VCF Management > Components reflects an IP address rather than an fqdn for the VCF Operations entry
  • Log symptoms:
    • SDDC Manager log /var/log/vmware/domainmanager/domainmanager.log contains this logging:

YYYY-MM-DDThh:mm:ss.sss+0000 DEBUG [vcf_dm,####,####] [c.v.v.v.s.f.FleetLcmApiRetryWrapper,dm-exec-####]  Non-retryable error encountered for operation 'Fleet LCM getComponents for <vcf_operations_fqdn>': Failed to find component of type OPS with FQDN <vcf_operations_fqdn>

YYYY-MM-DDThh:mm:ss.sss+0000 ERROR [vcf_dm,####,####] [c.v.e.s.c.util.RetriableCallable,dm-exec-####]  Non retriable exception while retrying operation
com.vmware.evo.sddc.orchestrator.exceptions.OrchTaskException: Failed to find component of type OPS with FQDN <vcf_operations_fqdn>

YYYY-MM-DDThh:mm:ss.sss+0000 ERROR [vcf_dm,####,####] [c.v.e.s.o.model.error.ErrorFactory,dm-exec-####]  [####] FLEET_ADD_CLOUD_PROXY_NODE_INPUT_PREPARATION_FAILED Input preparation for adding VCF Cloud Proxy node to existing VCF Operations has failed
com.vmware.evo.sddc.orchestrator.exceptions.OrchTaskException: Input preparation for adding VCF Cloud Proxy node to existing VCF Operations has failed

Environment

VCF 9.1.0.0100

Cause

The VCF Operations master node is registered in the SDDC Manager lifecycle databases (fleetlcm and sddclcm) using its IP address instead of its fqdn in the hostname field.

The VCF Installer fails to locate the component because it performs lookups based on the fqdn.

Querying GET /casa/node/status on the VCF Operations node incorrectly reports an IP address instead of the expected fqdn (in a browser, open URL - https://<vcf_operations_fqdn>/casa/node/status).

Resolution

Please open a case with Broadcom Technical Support and reference this article to have the issue resolved.