wcp process within the vCenter Server Appliance increases over time, leading to memory exhaustion alarms.vCenter Server 8.x
This issue is caused by a memory leak in the Workload Control Plane (wcp) service's internal client management (vmopClient) and a failure to properly close response bodies.
This leak occurs during service reconciliation loops, leading to a gradual accumulation of memory and file descriptors over time.
This issue is scheduled to be resolved in future release.
you can reclaim the leaked memory by restarting the wcp service.
service-control --restart wcp