Error: Installation failed - Precheck failed during vCenter patching using ISO file
search cancel

Error: Installation failed - Precheck failed during vCenter patching using ISO file

book

Article ID: 450683

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to patch or update a vCenter Server Appliance (VCSA), the process fails at 71%.
  • The pre-check before the patching process does not show any errors.
  • The following error is observed in the Appliance management page:



  • The /var/log/vmware/applmgmt/update_microservice.log contains the following error:
    DEBUG - [Errno 2] No such file or directory: '/storage/seat/software-update####/stage/pkg_list'", 'failed', 'Running Install Prechecks'
    DEBUG - UpdateTask: status=RESUMABLE, progress=0, message={'id': 'com.vmware.appliance.plain_message', 'default
    _message': '%s', 'args': ['Installation failed due to an exception']}, failure_state=None

Environment

vCenter Server 8.0.x

Cause

  • This issue occurs when the vCenter patch ISO is disconnected or unmounted during the pre-check or staging process.
  • Once the ISO is disconnected, the update microservice loses the path to the required package list (pkg_list), leaving the appliance in an inconsistent software update state.

Resolution

  1. Ensure the correct vCenter patch ISO is mounted to the vCenter Server Appliance CD/DVD drive and that the "Connected" box is checked in the vSphere Client settings for the VM.
  2. Log in to the vCenter Server via SSH as the root user and type "shell" to enter the BASH interface.
  3. Stop the Appliance Management Service by running the following command:
    service-control --stop applmgmt

  4. Rename the existing state configuration file to allow the service to generate a new one:
    mv /etc/applmgmt/appliance/software_update_state.conf /etc/applmgmt/appliance/software_update_state.conf.bak

  5. Start the Appliance Management Service by running the following command:
    service-control --start applmgmt

  6. Log into the VAMI (https://<vcenter-fqdn>:5480) and initiate the update.
  7. The process should now proceed past the pre-check phase.

Additional Information

Related KB article:
Accessing the VAMI returns error: "Update installation in progress"