NSX Edge Deployment Fails with Error: Failed to Connect to Host on Port 443
search cancel

NSX Edge Deployment Fails with Error: Failed to Connect to Host on Port 443

book

Article ID: 450608

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Edge node deployments fail during the VMDK transfer phase, and the NSX UI displays the following error message:
    Error occurred during vmdk transfer. Failed to connnect to host <fqdn> on port 443 from NSX. Fix the connectivity and retry the operation
  • Port connectivity from NSX Manager to ESXi host is working which can be verified by running the command on NSX Manager CLI with root login:-

nc -zv <ESXi_Host_IP> <tcp port no>

Environment

VMware NSX

Cause

The NSX Manager is unable to resolve the Fully Qualified Domain Name (FQDN) of the target host because the configured DNS servers are down or inaccessible.

Resolution

To resolve this issue and facilitate a successful Edge node installation, please fix the DNS server reachability issues.

Alternatively, as a temporary workaround, manually add the host entry to the local hosts file on the NSX Manager.

  1. Log in to the NSX Manager command line as root. Refer Enable ssh root access for NSX appliances

  2. Open the /etc/hosts file using a text editor.

  3. Add the IP address and FQDN of the target host.

  4. Save the file and retry the Edge node deployment operation.

Additional Information

NSX Manager Deployment Fails with "Error occurred during vmdk transfer. Failed to connect to host <hostname.fqdn> on port 443"