Error: Invalid hard disk parameters specified. The following parameters are invalid or conflict with other configured devices in the virtual machine
search cancel

Error: Invalid hard disk parameters specified. The following parameters are invalid or conflict with other configured devices in the virtual machine

book

Article ID: 450597

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When attempting to detach Named disks from Kubernetes VM's the following error is observed in the cloud director UI: 

    com.vmware.vcloud.api.presentation.service.BadRequestException: Invalid hard disk parameters specified. The following parameters are invalid or conflict with other configured devices in the virtual machine: [vcId=########-####-####-####-############, moref=vm-######] Adapter Type: SCSIPARAVIRTUAL, Bus Number: X, Unit Number: X
  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log, you see entries similar to:

    com.vmware.vcloud.api.presentation.service.BadRequestException: Invalid hard disk parameters specified. The following parameters are invalid or conflict with other configured devices in the virtual machine: [vcId=########-####-####-####-############, moref=vm-######] Adapter Type: SCSIPARAVIRTUAL, Bus Number: X, Unit Number: X
     at com.vmware.vcloud.fabric.storage.disk.impl.DiskUtils.getDiskInVm(DiskUtils.java:535)
     at com.vmware.vcloud.fabric.storage.disk.impl.DetachDiskActivity$DetachDiskFromVmPhase.invoke(DetachDiskActivity.java:161)
     at com.vmware.vcloud.activity.executors.ActivityRunner.runPhase(ActivityRunner.java:175)
     at com.vmware.vcloud.activity.executors.ActivityRunner.run(ActivityRunner.java:112)
     at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
     at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
     at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
     at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
     at java.base/java.lang.Thread.run(Thread.java:829)

Environment

VMware Cloud Director 10.6.X

Cause

This issue occurs because the vm_disk table contains a stale entry for the disk to be detached.

Resolution

To resolve this issue, contact Broadcom Technical Support and note this Knowledge Article ID (450597) in the problem description. For more information, see How to Submit a Support Request