Error: SpectrumCause.pl Row length for key is longer than limit 4096 - Spectrum
search cancel

Error: SpectrumCause.pl Row length for key is longer than limit 4096 - Spectrum

book

Article ID: 450593

calendar_today

Updated On:

Products

Network Observability Spectrum

Issue/Introduction

When running the SpectrumCause.pl integration script for Netcool, logs indicate data truncation with the message: SpectrumCause.pl: Chop column PROBABLE_CAUSES or TITLE

 

We see output like the following:

  • /data/gnslocal/spectrum/bin/netcool/SpectrumCause.pl: Row length for key 0x04bd1038 is longer than limit: 5674
  • /data/gnslocal/spectrum/bin/netcool/SpectrumCause.pl: Chop column PROBABLE_CAUSES from 5352 to 3773
  • /data/gnslocal/spectrum/bin/netcool/SpectrumCause.pl: Row length for key 0x01169c30 is longer than limit: 7193
  • /data/gnslocal/spectrum/bin/netcool/SpectrumCause.pl: Chop column TITLE from 7178 to 4080

Environment

  • DX NetOps Spectrum any version
  • Netcool Integration

Cause

This occurs when alarm data length exceeds the 4096-byte limit for the target database key or column.

Resolution

The recommendation would be to consult IBM as they provided the script.  Right in the comments it states:

"The longest column will get reduced if total row length is longer than 4096 (limit for lookup table row)."

So if you attempt to work around the Perl script's restriction, the generated .lookup file will likely cause errors when the Netcool probe attempts to ingest it.

Additional Information

If you need to speak with a customer representative or a Support Engineer, see Contact Support. Scroll to the bottom of the page and click on your respective region.