When running the SpectrumCause.pl integration script for Netcool, logs indicate data truncation with the message: SpectrumCause.pl: Chop column PROBABLE_CAUSES or TITLE.
We see output like the following:
This occurs when alarm data length exceeds the 4096-byte limit for the target database key or column.
The recommendation would be to consult IBM as they provided the script. Right in the comments it states:
"The longest column will get reduced if total row length is longer than 4096 (limit for lookup table row)."
So if you attempt to work around the Perl script's restriction, the generated .lookup file will likely cause errors when the Netcool probe attempts to ingest it.
If you need to speak with a customer representative or a Support Engineer, see Contact Support. Scroll to the bottom of the page and click on your respective region.