Uninstalling the VKS cluster management service, fails with the following error:
1/4 element(s) failed
Get "https://seaweedfs-s3.vmsp-platform.svc.cluster.local:8443/vcfa-service-manager-storage-bucket/?delimiter=&encoding-type=url&fetch-owner=true&list-type=2&prefix=addons%2Fbroadcom%2Fauto-attach-service%2F0.1.0": dial tcp ##.##.##.##:8443: connect: connection refused
/var/log/services-logs/prelude/tenant-manager-0/file-logs/vcloud-container-debug.log
####-##-## stderr F {"level":"error","ts":#############,"msg":"Reconciler error","controller":"supervisorservice","controllerGroup":"vcd.addon.vcf.vmware.com","controllerKind":"SupervisorService","SupervisorService":{"name":"broadcom.auto-attach-service-0.1.0-auto-attach-service","namespace":"prelude"},"namespace":"prelude","name":"broadcom.auto-attach-service-0.1.0-auto-attach-service","reconcileID":"############################","error":"endpoint https://<tenant-manager.prelude.svc.cluster.local>:443/proxy/vc/urn:vcloud:vimserver:################################/api/vcenter/namespace-management/supervisors/summaries failed: {\"error_type\":\"UNAUTHENTICATED\",\"messages\":[{\"args\":[],\"default_message\":\"Authentication required.\",\"id\":\"com.vmware.vapi.endpoint.method.authentication.required\"}]}","errorVerbose":"endpoint https://tenant-manager.prelude.svc.cluster.local:443/proxy/vc/urn:vcloud:vimserver:###########################################/api/vcenter/namespace-management/supervisors/summaries failed.:
VCF Automation 9.0.2
The primary issue is caused by the Tenant Manager retaining a stale vCenter (VC) session ID, which leads to authentication failures (such as a 401 Unauthorized status) when the VCFA proxy attempts to authenticate against vCenter.
Resolution:
To resolve the primary authentication issue and force the generation of a new session ID:
Log in to the VCFA Provider Portal.
Navigate to the Connections tab.
Click Reconnect on the affected vCenter connection.