VCF installation (converge) using brownfield vSphere deployments with VCF Operations, where continuous availability is enabled for the VCF Operations cluster, fails with the following error:
"The Fleet lifecycle 'Update component' task with ID ######-####-####-####-############ failed. Internal errors: Task with ID '######-####-####-####-############' from SDDC lifecycle with ID '######-####-####-####-############' has completed with failure(s). Check the errors in the next sub-task(s) for more details., Adding nodes to VCF Operations cluster is not allowed when Continuous Availability (CA) is enabled. Disable CA on the VCF Operations cluster before adding new nodes., Adding nodes to VCF Operations cluster is not allowed when Continuous Availability (CA) is enabled. Disable CA on the VCF Operations cluster before adding new nodes. Reference Token: 6VK0ES"Note: The reference token will change.
VMware Cloud Foundation 9.1.x
The fix will be available in future releases.
vmware-system-user (the password is the same as the VCF Service Runtime system user password).sudo su
export KUBECONFIG=/etc/kubernetes/admin.confkubectl edit cm vcf-sddc-build-service-sddcbuild-application-properties -n vcf-sddc-lcmdata:
application.properties: ""to:data:
application.properties: |
ops.ca.validation.disabled=trueNote: If
application.propertiesis not empty and contains other properties, insertops.ca.validation.disabled=trueon a new line.
kubectl rollout restart deployment -n vcf-sddc-lcm -l app=sddcbuildkubectl get pods -n vcf-sddc-lcm -l app=sddcbuildkubectl edit cm vcf-sddc-build-service-sddcbuild-application-properties -n vcf-sddc-lcmdata:
application.properties: ""kubectl rollout restart deployment -n vcf-sddc-lcm -l app=sddcbuildkubectl get pods -n vcf-sddc-lcm -l app=sddcbuild