Configure Offline Depot for VCF Installer error "The depot user or password is invalid Please ensure that correct depot user or password are provided"
search cancel

Configure Offline Depot for VCF Installer error "The depot user or password is invalid Please ensure that correct depot user or password are provided"

book

Article ID: 450549

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

Configuring an offline depot for the VCF 9.1 installer fails to connect with error
"The depot user or password is invalid Please ensure that correct depot user or password are provided"

Password and user are correct, permissions are set up as well.



Lcm logs show a 403 error

lcm-debug.log

<Date && Time> ERROR (C.v.e.8.1.b.d.depot.Depotbowsloader,http-nto-127.0.0. 1-7400-exec-7] Error getting file size, got response: 403 Forbidden WTTP/1.1
<Date && Time> ERROR (C.v.e.8.1.b.d.depot.Depotbowsloader,http-nto-127.0.0. 1-7400-exec-7] Got Http error[403] while downloading file [https://<IP_of _Offline_Depot>:443/PR00/mtadata/predrtVersianatalog/v1/productVersionCatalag.json] from<IP_of _Offline_Depot> with user <Username>

Environment

VCF 9.X/ 9.1

Cause

improper path on the Apache server, see  walkthrough and Set Up an Offline Depot

The procedure uses /var/www/html as the document root directory for the web server.
The directory must exist or you must manually create it by running the mkdir -p /var/www/html command.
 

Resolution

Review the documentation on how to Set Up an Offline Depot and follow the step by step walkthrough