esxcli storage nfs41 param set -r <FQDN>
Example:
## esxcli storage nfs41 list
Volume Name Host(s) Share Vmknics Accessible Mounted Connections Read-Only Security isPE Hardware Acceleration
----------- ----------------- ------ ------- ---------- ------- ----------- --------- -------- ----- ---------------------
vol3 examplenfsserver.com store3 None false false 1 false AUTH_SYS false Unknown
##esxcli storage nfs41 param set -r examplenfsserver.com
Error: 0x301: Failed to re-resolve hostname examplenfsserver.com: Re-resolution failed for one or more volumes, please check hostd logs and vmkernel logs for more info./var/run/log/hostd.log will log the below error: UpdateMountPointIPAddress: Failed to update IP address from 10.161.##.## to 10.161.##.##: Module(nfs41client) Instance(vol3) Input(10.161.##.##, 10.161.##.##, 1): Failure: VSI node (5011:)
var/run/vmkernel.log will log the below error:NFS41: NFS41Vsi_UpdateServerIP:4443: Updating Server IP from 10.161.##.## to 10.161.##.## with updateOnlyMultipath True for volumeNFS41: NFS41FSUpdateMultipath:11462: Skipping IP update in multi-path for FS vol3, Reason: mount-retry-in-progress
For Case 2 above
When using a Fully Qualified Domain Name (FQDN) during a reboot, mounts are resolved. If DNS resolution succeeds but the resulting IP address is unreachable, the mounts enter a retry state. In this state, if subsequent DNS re-resolution attempts fail, wait approximately 30 seconds before trying again. Deferring the DNS re-resolution operation for 30 seconds ensures alignment with the nfs41client, which performs mount retry operations every 30 seconds.