Limitation and Constraints for NFS41 DNS re resolution
search cancel

Limitation and Constraints for NFS41 DNS re resolution

book

Article ID: 450548

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • A new feature has been introduced from the VMware Cloud Foundation 9.1 and VMware vSphere ESXi 9.1 release onwards that enables DNS re-resolution for the NFS server FQDN. More information in Refreshing NFS Server IP Addresses for DNS-Mounted Datastores
  • This Knowledge Base article outlines the primary operational constraints when executing the command to re-resolve the provided FQDN across all volumes:

esxcli storage nfs41 param set -r <FQDN>

  • Please note the following two operational constraints:
    1. Case 1: NFS Server Failover: Do not trigger an FQDN re-resolution while a failover operation is actively occurring on the NFS server.
    2. Case 2: Unmounted Volumes: The re-resolution command will fail for any volumes that are currently unmounted, specifically those where the Mounted state is set to false (i.e., Mounted=false).

Example:

## esxcli storage nfs41 list

Volume Name          Host(s)               Share   Vmknics   Accessible  Mounted   Connections   Read-Only    Security    isPE    Hardware Acceleration
-----------      -----------------        ------   -------  ----------   -------   -----------   ---------    --------    -----   ---------------------
vol3               examplenfsserver.com   store3   None    false          false    1             false       AUTH_SYS    false      Unknown

##esxcli storage nfs41 param set -r examplenfsserver.com
Error: 0x301: Failed to re-resolve hostname examplenfsserver.com: Re-resolution failed for one or more volumes, please check hostd logs and vmkernel logs for more info.
  • /var/run/log/hostd.log will log the below error:

UpdateMountPointIPAddress: Failed to update IP address from 10.161.##.## to 10.161.##.##: Module(nfs41client) Instance(vol3) Input(10.161.##.##, 10.161.##.##, 1): Failure: VSI node (5011:)

  • var/run/vmkernel.log will log the below error:

NFS41: NFS41Vsi_UpdateServerIP:4443: Updating Server IP from 10.161.##.## to 10.161.##.## with updateOnlyMultipath True for volume
NFS41: NFS41FSUpdateMultipath:11462: Skipping IP update in multi-path for FS vol3, Reason: mount-retry-in-progress

Resolution

For Case 2 above

When using a Fully Qualified Domain Name (FQDN) during a reboot, mounts are resolved. If DNS resolution succeeds but the resulting IP address is unreachable, the mounts enter a retry state. In this state, if subsequent DNS re-resolution attempts fail, wait approximately 30 seconds before trying again. Deferring the DNS re-resolution operation for 30 seconds ensures alignment with the nfs41client, which performs mount retry operations every 30 seconds.