'Data Retriever is not initiated yet, please wait' message received on the Aria Operations user console
search cancel

'Data Retriever is not initiated yet, please wait' message received on the Aria Operations user console

book

Article ID: 450547

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • When logging into the Aria Operations (or VCF Operations) UI, the following error is displayed:
    • Data Retriever is not initialized yet, please wait
  • Cluster Status:
    • Primary and Data nodes appear in a "Running" state but report "Waiting for Analytics."
    • Primary Replica node is in an "Inaccessible" state.
    • Cluster Status is "Online," but HA status is "Activated, degraded."

Environment

VCF Operations 9.x

Cause

One of the cluster nodes has lost network connectivity, causing it to become inaccessible to the rest of the cluster. This isolation results in the failure of the Analytics service to initialize across the cluster, triggering the "Data Retriever" error and degrading High Availability. A host crash in the underlying infrastructure, if running a VCF Ops node, can also lead to this scenario.

Resolution

  1. Restore Network Connectivity:

    • Verify the virtual network adapter (vNIC) status of the "Inaccessible" node (e.g., Primary Replica) in vCenter.
    • If disconnected, reconnect the vNIC to the appropriate port group/segment.
    • If a direct connection fails, toggle the vNIC by switching it to a different port group and back to the correct segment to trigger a binding update.
    • Wait for the node to return to a "Running" or "Online" state in the Admin UI.
  2. Recover Cluster State:

    • Once the node is accessible, navigate to the Admin UI (https://<FQDN_or_IP>/admin).
    • Click Take Cluster Offline.
    • Perform a graceful Shut Down Guest OS for all nodes in the cluster.
    • Power on all nodes in the correct order (Primary node first, followed by Primary Replica, then Data nodes).
    • Once all nodes are powered on and reporting status in vCenter, navigate back to the Admin UI and click Bring Cluster Online.

Additional Information

Shut Down VCF Operations

Start VCF Operations

Shutdown and Startup sequence for VCF/Aria Operations cluster