CA OSIM Image-Not Able to deploy Image from Scalability Server
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Article ID: 45054
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Updated On:
Products
CA Client Automation - IT Client ManagerCA Client AutomationCA Client Automation - Software Delivery
Issue/Introduction
When using Operating System Installation Management (OSIM) to deploy an OS Image to a PC via a Scalability Server the following error is received:
Error OSM010014: The Image is not available on the boot server:<Scalability Server Name
Environment
Client Automation - All Versions
Cause
It is possible to cause duplicate entries in the database for the same Bootserver in the CSMDB tables of the MDB.
This can cause some unexpected issues when the wrong Bootserver record is looked up.
Example:
Can't read additional parameter file: \\...CA\DSM\Server\SDBS\var\managedpc\images\dosboot\parms\180373E25F95.dat: No such file or directory
Error : OSM010014: The OS Image is not available on the boot server:xxxxxxxx. But image is clearly available on the boot server Image Library.
OS Image is displayed in the SS OS Image library but when trying to select it has a red x and cannot be selected
Boot server listed multiple times in the boot server selection pane of OS Installation Wizard
Resolution
Identify and remove duplicate boot server records:
Step 1. Identify the incorrect record
Log a support case and request T1ED253
On Domain Manager: apply the test fix T1ED253 ( Please note this test fix is version independent)
Change into folder ...CA\DSM\bin
Run the command:
ccsmcmd listbootserver -u<user> -p<password>
This will show the two boot server entries
<bootserver>
<bootserver>
On the running Scalability Server run the commands
caf setcomputername %computername%temp
caf stop
caf start
on Domain Manager run the command to list the bootservers again:
ccsmcmd listbootserver -u<user> -p<password>
This will now show
<bootserver>
<bootservertemp>
The incorrect entry is now identified as it has not changed with renaming of the Scalability Server.
It is possible to use a script to run step 1D if there are many SS to rename.
If you receive the message “This setting cannot be changed because it is controlled by DSM Policy” on Step 1D above, you need to change this to locally managed in configuration policy.
Create a new config policy that can be applied to all Scalability servers
In this policy expand DSM\Agent
Right Click on "Use Operating system name for this agent" and choose "Setting" "Locally Managed"
Seal and apply this policy to your Scalability Servers and you can now run the “caf setcomputername” command
Step 2. Remove the duplicate records:
Delete the "old" boot server <bootserver> by running the command: