VMware Live Recovery:追加のネットワークアダプタの構成にてレプリケーションマッピングテストがエラーとなります。
search cancel

VMware Live Recovery:追加のネットワークアダプタの構成にてレプリケーションマッピングテストがエラーとなります。

book

Article ID: 450504

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware Live Recovery

Issue/Introduction

VMware Live Recovery (VLR)  をデプロイ後、vSphere Replication のネットワークアダプタを追加し、受信トラフィック (eth1) を管理トラフィック (eth0) とは分離させた構成においてレプリケーションを設定して同期を実行した直後にエラーが発生し、同期が失敗する事象が発生します。

保護サイトのホスト  の hbr-agent.log に以下のエラーメッセージが記録されます。

Failed to connect to "DR サイトの VLR  eth0 の IP アドレス":32032. Using nic 'vmk#'. Error: Connection timed out
Failed to bind to any of the specified VMKs for connection to "DR サイトの VLR  eth0 の IP アドレス":32032
Failed to connect to broker on "DR サイトの VLR  eth0 の IP アドレス":32032: Input/output error
Failed to connect to broker: Input/output error

Environment

VMware Live Recovery 9.0.5

Cause

VMware Live Recovery (VLR) アプライアンスの構成ファイル /opt/vmware/etc/hbr/hbrsrv-nic.xml 内の <ipForFilter> に、受信トラフィック用ネットワークアダプタ (eth1) ではなく、デフォルトのネットワークアダプタ (eth0) のIPアドレスが設定されています。これにより、対向ホストからの接続要求がタイムアウトし、同期が失敗します。

Resolution

各 VLR の hbrsrv-nic.xml の IP アドレスを eth1 の IP アドレスに変更します。

1.VLRアプライアンスに admin ユーザーでSSH接続します。
2.su root コマンドを実行し、rootユーザーに変更します。
3./opt/vmware/etc/hbr ディレクトリに移動します。

  cd /opt/vmware/etc/hbr

4.構成ファイルのバックアップを取得します。  

  例:cp hbrsrv-nic.xml hbrsrv-nic.bkup

5.テキストエディタ (vi など) で hbrsrv-nic.xml を開き、<ipForFilter> の値を eth1 のIPアドレス に変更します。

  <config><ipForHMS /><ipForFilter>eth1のIPアドレス</ipForFilter><ipForNFC /></config>

6.設定を反映させるため hbrsrv, hms サービスを再起動します。 

  systemctl restart hbrsrv
  systemctl restart hms


  サービスが正常に起動していることを確認します。 

  systemctl status hbrsrv
  systemctl status hms

複合型 VMware Live Recovery アプライアンス上の受信レプリケーション トラフィックで使用する仮想マシン ネットワーク アダプタの作成

※ 保護サイトとDRサイトが異なるサブネットに配置されている場合、追加のネットワークアダプタでのスタティックルートの構成も必要となります。

追加の仮想マシン ネットワーク アダプタでのスタティック ルートの構成