Patching vCenter fails due to stopped services
search cancel

Patching vCenter fails due to stopped services

book

Article ID: 450413

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Patching pre-checks fails with message 
Error
vCenter service(s) <lookupsvc, vmware-stsd> are stopped.
Resolution
Start the vCenter service(s) using the command: 'service-control --start <servicename>'
  • Checking services via SSH you see multiple services not running.
  • In lookupsvc_stream.log.stderr located in /var/log/vmware/lookupsvc you see following error 

 

Traceback (most recent call last):
  File "/usr/sbin/cloudvm-ram-size", line ###, in <module>
    main()
  File "/usr/sbin/cloudvm-ram-size", line ###, in main
    setupLogging(logName, logMechanism='file', logDir=logDir,
  File "/usr/lib/vmware/site-packages/cis/utils.py", line ###, in __init__
    self._setupFileLogging(program, level=level, logDir=logDir,
  File "/usr/lib/vmware/site-packages/cis/utils.py", line ###, in _setupFileLogging
    fileHandler = CustomPermissionRotatingFileHandler(umask, logFile,
  File "/usr/lib/vmware/site-packages/cis/utils.py", line ###, in __init__
    super(CustomPermissionRotatingFileHandler, self).__init__(*args, **kwargs)
  File "/usr/lib/python3.10/logging/handlers.py", line ###, in __init__
    BaseRotatingHandler.__init__(self, filename, mode, encoding=encoding,
  File "/usr/lib/python3.10/logging/handlers.py", line ##, in __init__
    logging.FileHandler.__init__(self, filename, mode=mode,
  File "/usr/lib/python3.10/logging/__init__.py", line ###, in __init__
    StreamHandler.__init__(self, self._open())
  File "/usr/lib/vmware/site-packages/cis/utils.py", line ###, in _open
    rtv = logging.handlers.RotatingFileHandler._open(self)
  File "/usr/lib/python3.10/logging/__init__.py", line ###, in _open
    return open_func(self.baseFilename, self.mode,
PermissionError: [Errno 13] Permission denied: '/var/log/vmware/cloudvm/cloudvm-ram-size.log

 

  • Running history command you see that permissions was changed for following

 

chown root:root /var/log/vmware/cloudvm
chown root:root /var/log/vmware/cloudvm/example.log

 

 

 

 

Environment

VCSA 8.x

Cause

Incorrect permissions on folder cloudvm  and .log  files located in /var/log/vmware/

Resolution

  1. Change permission of folder cloudvm located in /var/log/vmware/ to default ones with running following command

 

chown root:cis /var/log/vmware/cloudvm
  1. Change permission of .log file  located in /var/log/vmware/ to default ones with running following command
chown root:cis /var/log/vmware/cloudvm/example.log