Client tools error: Unknown error 0x800A0E7A while trying to connect Database
search cancel

Client tools error: Unknown error 0x800A0E7A while trying to connect Database

book

Article ID: 4504

calendar_today

Updated On: 04-23-2025

Products

CA Identity Governance CA Identity Suite

Issue/Introduction

Installed client tools on Windows 2012 but getting below error while trying to connect database.

Unknown error 0x800A0E7A: Provider cannot be found. it may not be properly installed.

I tried uninstall and install multiple times but getting the same error.

Environment

Identity Governance 14.x

Cause

Database client tools may have been installed AFTER the Identity Governance Client tools, this should be done before.

Resolution

Uninstall and Reinstall the database client tools with the Identity Governance Client tools installed.

You have to pick one of these to install and a requirement to installing the Client tools

MS SQL Server, SQL Client

     

    Oracle Client:

    1. Download an Oracle Client installation package that is compatible with the target Oracle server from the Oracle website to the computer that hosts Identity Governance Client Tools.

    2. Run the Oracle Client installer and install the following components:

    • Oracle Database Utilities
    • SQL*Plus
    • Oracle Windows Interfaces components:
      Oracle Objects for OLE
      Oracle Provider for OLE DB


    3. Unzip the Oracle Client installer.

    4. Create a tnsnames.ora file that defines the connection to the main Identity Governance database on the Oracle server.

    For example, the following code defines a TCP link to the rcm_sdb database on the XE database server.
    XE = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = ORAC01.com)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED)(SERVICE_NAME =rcm_sdb)) )

    5. Copy

    Copy the tnsnames.ora file to the following directory:
    Oracle_home\network\admin

    Additional Information

    For further information, see the document Install Additional Components