When Edge Clusters are created via NSX Manager and imported after the initial 9.0 deployment, the import process fails to include the management_ip_address field for the edge nodes. Consequently, SDDC Manager backups will fail in environments that contain these imported out-of-band edge nodes.
Imported Edge Clusters.
curl localhost/inventory/nsxt-edgeclusters?id=<EDGE_CLUSTER_ID> | jq > edge_cluster.json
Example Output (cat edge_cluster.json):[
{
"clusterIds": [
"<VSPHERE_CLUSTER_ID>"
],
"nsxtClusterId": "<NSXT_CLUSTER_ID>",
"id": "<EDGE_CLUSTER_ID>",
"edgeClusterNsxtId": "<EDGE_CLUSTER_NSXT_ID>",
"name": "<EDGE_CLUSTER_NAME>",
"status": "ACTIVE",
"nsxtEdgeNodes": [
{
"id": "<EDGE_NODE_1_ID>",
"hostName": "<EDGE_NODE_1_FQDN>",
"edgeNodeNsxtId": "<EDGE_NODE_1_NSXT_ID>"
},
{
"id": "<EDGE_NODE_2_ID>",
"hostName": "<EDGE_NODE_2_FQDN>",
"edgeNodeNsxtId": "<EDGE_NODE_2_NSXT_ID>"
}
],
"isTier0ManagedBySystem": true,
"skipTepRoutabilityCheck": false,
"originType": "CLASSIC",
"applianceType": "EDGE_NODE"
}
]
{
"clusterIds": [
"<VSPHERE_CLUSTER_ID>"
],
"nsxtClusterId": "<NSXT_CLUSTER_ID>",
"id": "<EDGE_CLUSTER_ID>",
"edgeClusterNsxtId": "<EDGE_CLUSTER_NSXT_ID>",
"name": "<EDGE_CLUSTER_NAME>",
"status": "ACTIVE",
"nsxtEdgeNodes": [
{
"id": "<EDGE_NODE_1_ID>",
"hostName": "<EDGE_NODE_1_FQDN>",
"managementIpAddress": "<EDGE_NODE_1_IP>",
"edgeNodeNsxtId": "<EDGE_NODE_1_NSXT_ID>"
},
{
"id": "<EDGE_NODE_2_ID>",
"hostName": "<EDGE_NODE_2_FQDN>",
"managementIpAddress": "<EDGE_NODE_2_IP>",
"edgeNodeNsxtId": "<EDGE_NODE_2_NSXT_ID>"
}
],
"isTier0ManagedBySystem": true,
"skipTepRoutabilityCheck": false,
"originType": "CLASSIC",
"applianceType": "EDGE_NODE"
}curl -X PUT -H "Content-Type: application/json" --data @edge_cluster.json localhost/inventory/nsxt-edgeclusters/<EDGE_CLUSTER_ID> | jqcurl localhost/inventory/domains | jq curl localhost/inventory/domains/<DOMAIN_ID>/inventory | jqOnce all missing IPs are updated, retry the SDDC Manager backup workflow from the UI.