NSX Manager でメトリックの収集が Errno 13 Permission denied で失敗する
search cancel

NSX Manager でメトリックの収集が Errno 13 Permission denied で失敗する

book

Article ID: 450356

calendar_today

Updated On:

Products

VMware NSX VCF Operations for Networks

Issue/Introduction

免責事項: これは英文の記事 「Failed to collect metrics Errno 13 Permission denied in NSX Manager(444599)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

VMware NSX は影響を受けるマネージャーノードの syslog に以下のエラーメッセージを継続的に生成します。

Failed to collect metrics, Exception:[Errno 13] Permission denied: '/var/log/nvpapi/api_server.log.##.gz'

この問題は数日間続く場合があり、機能の動作に影響を与えることはありませんがログ出力が継続的に行われます。

Environment

VCF Operataions for Networks

VMware NSX

Cause

メトリックコレクターは10分ごとにデータを取得しようとしますが、圧縮されローテーションされたログファイル (api_server.log.##.gz) を読み取るための必要なファイル権限がないため失敗します。これは、ログローテーションのサイクル中に特定のアーカイブファイルに不適切なファイル権限が割り当てられるために発生します。

Resolution

  • 直ちに対応する必要はありません。これは表面上のメトリック収集エラーであり、NSX Manager のパフォーマンスや安定性に影響を与えるものではありません。
  • この問題は、次回のログローテーションのサイクルで、不適切な権限を持つログファイル (api_server.log.10.gz) が上書きまたは削除される際に自動的に解決されます。
  • 次回のスケジュールされたローテーションの前に継続的なエラーのログ記録を手動で停止するには、管理者が影響を受ける .gz アーカイブのファイル権限を確認して修正することで停止することができます。