"Email test error: Invalid Addresses" when testing the Standard Email plugin connection
search cancel

"Email test error: Invalid Addresses" when testing the Standard Email plugin connection

book

Article ID: 450350

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • Attempting to configure the SMTP outbound Standard email plugin in VMware Cloud Foundation (VCF) Operations 9.1 fails when testing the connection with a recipient email address. The UI returns the following error:

    Test was not successful: Email test error: [Invalid Addresses]

  • The issue began occurring following an upgrade to VCF Operations 9.1.

  • The /storage/log/vcops/log/analytics-UUID.log displays the following errors:

    ERROR analytics [com.vmware.vcops.platform.notification.email.EmailSender.call] - Failed to send email Outbound Email message: 'Test email from VMware Cloud Foundation Operations outbound email plugin'; To: ; <receipient_email_address>; Invalid Addresses
    ERROR analytics [com.vmware.vcops.plugins.filter.EmailPlugin.test] - Email test failed: [Invalid Addresses]

  • The /storage/log/vcops/log/vcops-bridge.log displays:

    ERROR vcfops-bridge [ops@#### threadId="######" threadName="ServerConnection on port ##### Thread ###" operationId=""] [com.vmware.vcops.bridge.server.BridgeTracerAspect.processBridgeResult] - Email test error: [Invalid Addresses]
    

     

  • Testing the email from the CLI using command (curl -v --ssl-reqd --url smtp://<SMTP-FQDN>:<Port> --mail-from <Sender-Email-Emailaddress> --mail-rcpt <receipient_email_address> -F "text='Email Test'" ) also fails with a rejection from the SMTP server:

    root@<Hostname> [ ~ ]# curl -v --ssl-reqd --url smtp://<SMTP-FQDN>:<Port> --mail-from <Sender-Email-Emailaddress> --mail-rcpt <receipient_email_address> -F "text='Email Test'"
    
    Host <SMTP-FQDN>:<Port> was resolved.
    SSL certificate verified via OpenSSL.
    Established connection to <SMTP-FQDN>:<Port> from ###.##.###.## port #####
    > MAIL FROM:<Sender-Email-Emailaddress>  SIZE=###
    
    < 250 2.1.0 Ok
    
    > RCPT TO:<receipient_email_address>
    
    < 553 5.7.1 <Sender-Email-Emailaddress>: Sender address rejected: not logged in
    
    RCPT failed: 553
    shutting down connection #0
    curl: (55) RCPT failed: 553

Environment

VCF Operations 9.1

Cause

A metadata key rename in version 9.1.0 caused existing email plugins to drop their authentication setting, resulting in the SMTP server rejecting the connection.

Resolution

This issue will be fixed in the upcoming 9.1.1 release

For a workaround, please   Contact Broadcom Support and ensure that Article ID 450350 is noted in the problem description when submitting the case.

Additional Information

 For standard configuration details, refer to the official documentation: Adding Outbound Notification Plug-Ins