smkeyimport creates new four Agent Keys in the existing Key Store. This results in the duplicate set of Agent Keys.
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smkeyimport creates new four Agent Keys in the existing Key Store. This results in the duplicate set of Agent Keys.

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Article ID: 4503

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

The smkeyimport tool creates new four Agent Keys in the existing Key Store.

Environment

Policy Server 12.0, 12.5 OS: All

Cause

When running the smkeyimport tool, as the OIDs for the Agent Keys are different, it creats new Agent Keys object resulting in the duplicate set of Agent Keys.

Resolution

To avoid this situation of the duplicate set of Agent Keys, follow the steps below.

  1. Stop Policy Server.
  2. Delete all Agent Keys in the existing Key Store. (For detail, see TEC541461: Deleting All Keys)
  3. Run smkeyimport.
  4. Start Policy Server.

 

Additional Information

How to Clean up a SiteMinder Key Store?

https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=50770


Tech Tip : CA Single Sign-On:: Policy Server : Best practice on importing Agent Keys

https://community.broadcom.com/browse/blogs/blogviewer?BlogKey=2a17a576-79d3-4fc4-88b3-2779a826477c&CommunityKey=f9d65308-ca9b-48b7-915c-7e9cb8fc3295