DEBUG [vcf_lcm,0000000000000000,0000,actionExecutionId=87a6####,opId=9104####,taskId=f4d0####] [c.v.v.l.p.p.f.a.PrecheckAgentPollAction,AsyncTaskEngine142] Agent resource type: NSX, Precheck Result: PrecheckResult(taskId=aea6####, name=NSX Precheck Workflow, status=SUCCESSFUL, resourceResults=[ResourceResult(resource=Resource[resourceType=NSX_T_MANAGER, name=nsxw01.example.com], status=FAILED, validationResults=[ValidationResult(validationName=NSX planning phase precheck, validationStatus=FAILED, ERROR=[Notification(severity=ERROR, message=LocalizableMessage(id=com.vmware.vcf.error.runtime.upf.resource.validation.failed, defaultMessage=Failed to execute the resource validations))])])])
ERROR [vcf_dm,0000000000000000,0000] [c.v.v.c.n.s.impl.NsxtWs1bServiceImpl,ForkJoinPool.commonPool-worker-#####] Failed to fetch the OIDC end point info for nsxw01.example.com {"module_name":"common-services","error_message":"The credentials were incorrect or the account specified has been locked.","error_code":403}
com.vmware.evo.sddc.common.core.error.FederatedBrokerIdentityException: {"module_name":"common-services","error_message":"The credentials were incorrect or the account specified has been locked.","error_code":403}
psql -h localhost -U postgres -d platform -c "\x" -c "select id,cluster_fqdn,configuration from nsxt where cluster_fqdn='nsxw01.example.com'"Output:
-[ RECORD 1 ]-+-------------------------------------------------
id | da3f####-####-####-####-########971d
cluster_fqdn | nsxw01.example.com
configuration | ######################
| "auditError": {
| "errorCode": "Failed to load NSX Cluster from the Inventory",
| "errorDetails": "error_message : Failed to load NSX Cluster from the Inventory, httpStatus : , error_code : 0"The issue is caused by a credential mismatch between the SDDC Manager database and the NSX Manager appliance.
The audit account is disconnected in SDDC Password Management, resulting in a 403 Forbidden error when fetching OIDC endpoint information.
The SDDC platform database reflects a stalled audit state ("Failed to load NSX Cluster from the Inventory"), which prevents the precheck from successfully validating NSX resources.
To resolve this issue, remediate the audit credentials in NSX Manager and synchronize the SDDC Manager inventory.
Follow the below steps
get user audit password-expirationst e
chage -l audit