VCF Administrator Attempting Recovery VMFS on Snapshot Volume.
search cancel

VCF Administrator Attempting Recovery VMFS on Snapshot Volume.

book

Article ID: 450298

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Customer is unable to re-signature snapshot VMFS volume during an attempt to recover virtual machine data from an unspecified data impacting event..

  • The command output for 'esxli storage vmfs snapshot list' returns the following information:

Volume Name: ##########
VMFS UUID: ########-####-####-############
Can mount: false
Reason for un-mountability: some extents missing
Can resignature: false
Reason for non-resignaturability: some extents missing
Unresolved Extent Count: 1

 

Environment

  • All versions of Esxi 

Cause

At an unspecified time, an extent device was attached to this volume and was either removed or encountered an undefined error rendering the device unreadable/uncountable from a VMFS perspective.

The impacted region is the first 512MB-2GB of the volume header, which is missing, leading the device to not be recognized as a complete VMFS volume.

Resolution

Customer's experiencing this are scenario are encouraged engage a Data Recovery Partner, to assess the volume and provide further options on how best the data be recovered.