The region creation fails with the following error message:
Error while create-or-update SSO provider in https://<VC_FQDN>/api. Response status code: 400, Response body: {"messages":[{"args":["<UUID>","1"],"default_message":"Maximum number of configurable external identity providers reached for Supervisor <UUID>: found 1."In vcloud-container-debug logs (under /services-logs/prelude/) we see the above error, as well as:
com.vmware.vcloud.api.presentation.service.InternalServerErrorException: An SSO Provider already exist for this supervisor, its display-name is '<IdP-name>' VCFA 9.0.x
Region creation workflow registers VCFA as IDP in supervisor or try to use any existing IDP present in supervisor. Existing IDP should be a VCFA one in supervisor with specific display name or region creation fails.
It is not necessary to register the Supervisor as a client in VCF SSO and VCF SSO as IDP in supervisor.