Attempts to deploy a Virtual Machine from a Content Library or upload an OVF template fail with the following error: Resource inaccessible. Error getting https://<vCenter_FQDN>:443/cls/data/<path>/<OVA/OVF_Name>.ovf 500 Internal Server Error
search cancel

Attempts to deploy a Virtual Machine from a Content Library or upload an OVF template fail with the following error: Resource inaccessible. Error getting https://<vCenter_FQDN>:443/cls/data/<path>/<OVA/OVF_Name>.ovf 500 Internal Server Error

book

Article ID: 450258

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Deploying VM from Content Library fails with the following error on step 2 of deployment Wizard

Resource inaccessible. Error getting https://<vCenter_FQDN>:443/cls/data/<path>/<OVA/OVF_Name>.ovf: HTTP/1.1 500 Internal Server Error

This impacts all content library objects.

Unable to upload file to Content Library also.

Environment

vCenter 8.X

Cause

The datastore used for the Content Library is not accessible

The datastore MoRef vCenter is using is a stale/invalid MoRef

/var/log/vmware/content-library/cls.log shows entries similar to the following :

com.vmware.transfer.impl.NfcEndpointImpl$DatastoreException: Cannot find a host to transfer files on datastore '<DataStore_Name>'. Check that the datastore is properly mounted to at least one connected host, and that the total number of concurrent transfers is not beyond the maximum configured capacity of 8 per host.
YYYY-MM-DDTHH:MM:SS | DEBUG    | c856219a-8b77-4898-9d7e-3ce55d12b108-6c-f8 | transferService-priority-pool-8-thread-19 | TransferItemImpl               | Session <SESSION_ID>: no transfer scheduled due to source error for item <OVF_NAME.OVF>: Unable to obtain the ticket for transfer while downloading from datastore (ds:///vmfs/volumes/<PATH>//contentlib-<PATH>/<TEMPLATE_NAME>_serverId=<SERVER_ID>): Cannot find a host to transfer files on datastore '<DataStore_Name>'. Check that the datastore is properly mounted to at least one connected host, and that the total number of concurrent transfers is not beyond the maximum configured capacity of 8 per host..
...
YYYY-MM-DDTHH:MM:SS | DEBUG    | ms77blb6-19557-auto-f3a-h5:70003005-d9-85 | cls-simple-activity-5     | HttpUtil                       | HTTP GET from https://<VC_FQDN_OR_IP>:443/cls/data/<SESSION_ID>/<OVF_NAME.OVF> failed with status HTTP/1.1 500 Internal Server Error
defaultMessage = Resource inaccessible. Error getting https://<VC_FQDN_OR_IP>:443/cls/data/<SESSION_ID>/<OVF_NAME.OVF>: HTTP/1.1 500 Internal Server Error,
args = [https://<VC_FQDN_OR_IP>:443/cls/data/<SESSION_ID>/<OVF_NAME.OVF>, HTTP/1.1 500 Internal Server Error],
2026-07-30T10:52:17.176+02:00 | DEBUG    | <OP_ID> | tomcat-http-20            | TransferItemImpl               | Session <SESSION_ID>: Releasing transfer item <SESSION_ID>/<TEMPLATE_NAME>-2.nvram
2026-07-30T10:52:17.176+02:00 | DEBUG    | <OP_ID> | tomcat-http-20            | TransferItemImpl               | Session <SESSION_ID>: Releasing transfer item <SESSION_ID>/<OVF_NAME.OVF>
defaultMessage = Resource inaccessible. Error getting https://<VC_FQDN_OR_IP>:443/cls/data/<SESSION_ID>/<OVF_NAME.OVF>: HTTP/1.1 500 Internal Server Error,
args = [https://<VC_FQDN_OR_IP>:443/cls/data/<SESSION_ID>/<OVF_NAME.OVF>, HTTP/1.1 500 Internal Server Error],
 
 
Checking the List of Datastores on the vCenter Client / GUI will show more than one entry for the impacted datastore.
Only the valid datastore will list VM's, Hosts, Files etc 
The invalid/Stale datastore should show zero VM's, Hosts, Files etc 

Resolution

On the invalid/stale datastore entry in the vCenter Client

Right Click > Select 'Unmount Datastore ...'

( Do not select "Delete Datastore", which attempts to destroy filesystem partitions on disk ).

Once complete, perform a Rescan of Storage - https://knowledge.broadcom.com/external/article/308546/ 

Deploying VM from Content Library now succeeds.

Additional Information

https://knowledge.broadcom.com/external/article/308546/  Performing a rescan of the storage on an ESXi host.