While creating a VSVIP or Virtual Service, the operation fails with HTTP code 400 and the following error:
Encountered an error on POST request to URL https://localhost/api/ipamfactory/allocate-vip: HTTP code: 400; error from Controller: map[webapp_error:create_host_record_auto(['<SUBNET_IP>/<CIDR>']-vsvip-<UUID>) error[Error creating host_record on all given subnets, num_subnets[1] last_error({'network': '<SUBNET_IP>/<CIDR>'} - 404: { "Error": "AdmConDataNotFoundError: View <DNS_VIEW_NAME> not found", "code": "Client.Ibap.Data.NotFound", "text": "View <DNS_VIEW_NAME> not found" })]]
VMware Avi Load Balancer
Infoblox Integration (IPAM Profile)
The configured DNS View name is either missing or misspelled in Infoblox, or the API user lacks permissions to access it, hence leading to the issue.
Update the IPAM/DNS Profile in Avi with correct DNS view name :
Log into the Avi Controller UI.
Navigate to Templates > IPAM/DNS Profiles.
Edit the relevant Infoblox DNS Profile.
Under Credentials / Infoblox Configuration, set the DNS View field to match the exact name from Infoblox (or leave/set it to default).