The NSX-T Manager UI fails to load with error "Server is overloaded".
Review the following log file on the cloud proxy or data node for confirmation:
/storage/vcops/log/NSXTAdapter/NSXTAdapter_.log
You will see the following error:
ERROR [NSX-T Metric Collector thread, <date and time> com.vmware.adapter3.nsxt.util.NsxtApiUtil.getTransportNodeInterfaceStatistics - Node Interface Statistics properties not retrieved due to 429 error, retrying the API.Or view the logs from the UI if you do not have access to the appliances:
NSXTAdapter_<internal ID>.log. The newest log will not have a numerical value at the end.Note: To find the correct logs, first check the Integrations page to verify which collector the adapter instance is currently assigned to.
Excessive API calls from NSX-T adapter instance.
The NSX-T adapter instance is generating excessive API retries during the collection cycle, overwhelming the NSX-T management plane.
Lower the retry attempt from NSX-T adapter instance:
vi /usr/lib/vmware-vcops/user/plugins/inbound/NSXTAdapter3/conf/NSXT.propertiesAPI_RETRY_COUNT=1:wq