vmnics (Broadcom BCM57412 NetXtreme-E) go down or fail to pass traffic on ESXi host after updating from 8.0 U3f to version 8.0 U3j
search cancel

vmnics (Broadcom BCM57412 NetXtreme-E) go down or fail to pass traffic on ESXi host after updating from 8.0 U3f to version 8.0 U3j

book

Article ID: 450166

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

After updating an ESXi host from version 8.0 U3f to version 8.0 U3j , physical network adapters vmnic Broadcom BCM57412 NetXtreme-E exhibit inconsistent behavior, including nic showing down or failing to pass network traffic entirely.

Log (vmkernel.log) analysis reveals firmware crash events on the network interfaces along with the following message:

2026-07-30T00:14:25.019Z Wa (180) vmkwarning: cpu44:2097762) WARNING: bnxtnet: hwrm_send_msg: 391: [vmnicX : 0x4521c1740000] HWRM cmd resp len timeout, c
md_type 0x0 (HWRM_VER_GET) seq 3637
2026-07-30T00:14:25.019Z Wa (180) vmkwarning: cpu44:2097762) WARNING: bnxtnet: hwrm_get_version: 3233: [vmnicX : 0x4521c1740000] VER GET failed- FW STATUS REG: 0x89141
2026-07-30T00:14:25.019Z In (182) vmkernel: cpu44:2097762) bnxtnet: bnxtnet dump fw data: 336: [vmnicX : 0x4521c1740000] START OF FIRMWARE DUMP
2026-07-30T00:14:25.419Z In (182) vmkernel: cpu4: 2097762) bnxtnet: bnxtnet_dump fw_data: 341: [vmnicX : 0x4521c1740000] Taking FW Trace ...
2026-07-30T00: 14:30.179Z Wa (180) vmkwarning: cpu19:2098370) WARNING: bnxtnet: hwrm_send_msg: 391: [vmnicX : 0x4521c1740000] HWRM cmd resp len timeout, cmd type 0x23 (HWRM PORT QSTATS) seq 3638
and also, messages such as "waiting for queue flush responsein"




Environment

VMware vSphere ESXi

Cause

The issue is caused by a firmware crash on the Broadcom bnxtnet adapter, which forces the physical NICs into an unstable state where they fail to process queue flushes and stop passing traffic normally.

Resolution

Step 1: Evacuate the Host

Migrate all active Virtual Machines (VMs) off the affected ESXi host using vMotion and place the host into Maintenance Mode.

Step 2: Driver Reinstallation & Reset (Temporary Workaround) reference article

  1. Uninstall the current bnxtnet driver package from the ESXi host via CLI.
    esxcli software vib remove -n <vendor vib name> -f

  2. Reboot the ESXi host to complete the driver install (Note if management uses the uninstalled driver it will cause the host to go down, make sure to have a IDRAC or iLO etc)

    Reinstall the appropriate bnxtnet driver package.
    esxcli software vib remove -n <vendor vib name> -f

  3. Reboot the ESXi host to apply driver changes and re-initialize the network adapter firmware.

  4. Verify that vmnics are restored to an UP status and passing traffic normally.

Step 3: Hardware Vendor Engagement & Monitoring

  1. Monitor the specific host to ensure the bnxtnet firmware crash does not recur.

  2. Engage your hardware OEM/vendor to analyze the firmware core dumps to determine if underlying physical hardware replacement or a specific firmware update is required.

Additional Information

Broadcom KB 374362 - ESXi host experiences PSOD with network driver bnxtnet / firmware crash