After VC datastore was renamed and VC connection was updated in SSPI, some SSP pods was stuck at container creating stage with the error like:
Warning FailedAttachVolume 30m (x8 over 31m) attachdetach-controller AttachVolume.Attach failed for volume "pvc-a60f2ba9-4fb9-4c34-adc5-7ccffdb23d29" : rpc error: code = Internal desc = failed to attach disk: "5b2d21d2-6a7f-4e31-be98-6ec97ecac07c" with node: "4218c808-7732-1230-6420-8c3ed7508de7" err failed to attach cns volume: "5b2d21d2-6a7f-4e31-be98-6ec97ecac07c" to node vm: "VirtualMachine:vm-205 [VirtualCenterHost: <vCenter-fqdn>, UUID: 4218c808-####-####-####-8c3ed7508de7, Datacenter: Datacenter [Datacenter: Datacenter:datacenter-3, VirtualCenterHost: <vCenter-fqdn>]]". fault: "(*types.LocalizedMethodFault)(0x70efe0ad64c0)({\n DynamicData: (types.DynamicData) {\n },\n Fault: (types.CnsFault) {\n BaseMethodFault: (types.BaseMethodFault) <nil>,\n Reason: (string) (len=82) \"Failed to retrieve VStorageObjectAssociationsFault cause: vmodl.fault.SystemError\\n\"\n },\n LocalizedMessage: (string) (len=98) \"CnsFault error: Failed to retrieve VStorageObjectAssociationsFault cause: vmodl.fault.SystemError\\n\"\n})\n". opId: "4c1c9838"
VC 8.x
This issue is due to a VC bug as this VC KB mentioned: 371037
Follow the workaround in this VC KB : 371037