The BOSH director fails to start after about 5 minutes. You see an error similar to the following:
Started deploying
Waiting for the agent on VM 'vm-d0527930-EXAMPLE-52678dd335b8'... Finished (00:00:00)
Running the pre-stop scripts 'unknown/0'... Finished (00:00:00)
Stopping jobs on instance 'unknown/0'... Finished (00:00:01)
Running the post-stop scripts 'unknown/0'... Finished (00:00:00)
Unmounting disk 'disk-edd2d5cc-EXAMPLEeebb19fc0982.EXAMPLE='... Finished (00:00:10)
Deleting VM 'vm-d0527930-EXAMPLE-52678dd335b8'... Finished (00:00:36)
Creating VM for instance 'bosh/0' from stemcell 'sc-f7054123-EXAMPLE-3a9fdac92ace'... Finished (00:00:36)
Waiting for the agent on VM 'vm-b832bbfc-EXAMPLE-c9c65af6f20c' to be ready... Finished (00:00:34)
Attaching disk 'disk-edd2d5cc-EXAMPLE-eebb19EXAMPLE' to VM 'vm-b832bbfc-EXAMPLE-c9c65af6f20c'... Finished (00:00:37)
Rendering job templates... Finished (00:02:18)
Compiling package 'golang-1-linux/a9ec2c795feaf63781b15dbd1e965f39d67f'... Skipped [Package already compiled] (00:00:00)
...
Compiling package 'database-backup-restorer-postgres-16/0f7a70c489ad66cc581dba590235e42ebbbeed2f754'... Skipped [Package already compiled] (00:00:00)
Compiling package 'director/ffe30601244cbd5c93b18c43e69ef09b6'... Skipped [Package already compiled] (00:00:00)
Updating instance 'bosh/0'... Finished (00:00:50)
Waiting for instance 'bosh/0' to be running... Failed (00:05:03)
Failed deploying (00:11:57)
The monit summary command on the director shows that the metrics_server is down (not monitored):
bosh/0:~# monit summary
The Monit daemon 5.2.5 uptime: 15d 2h 7m
Process 'nats' running
Process 'bosh_nats_sync' running
Process 'postgres' running
Process 'director' running
Process 'worker_1' running
Process 'worker_2' running
Process 'worker_3' running
Process 'worker_4' running
Process 'worker_5' running
Process 'dynamic_disks_worker_1' running
Process 'dynamic_disks_worker_2' running
Process 'dynamic_disks_worker_3' running
Process 'director_scheduler' running
Process 'metrics_server' not monitored
Process 'director_sync_dns' running
Process 'director_nginx' running
Process 'health_monitor' running
Process 'uaa' running
Process 'credhub' running
Process 'system-metrics-agent' running
Process 'blobstore_nginx' running
Process 'count-cores' running
The log at /var/vcap/sys/log/director/metrics_server.stderr.log shows an error for "Duplicate vm type name"
/var/vcap/data/packages/director/4562e2940deb6390d3d1e38b/gem_home/ruby/3.3.0/gems/bosh-director-0.0.0/lib/bosh/director/deployment_plan/cloud_manifest_parser.rb:105:in `parse_vm_types': Duplicate vm type name 'example_type' (Bosh::Director::DeploymentDuplicateVmTypeName)
There are duplicate vm_type names in your BOSH cloud configs
Run bosh configs and check each cloud config. If any vm_type names appear more than once across the configs then they will need to be removed except for one. The names for vm_types must be unique