Internal error occurred: Please retry the operation or contact support if the issue persistsTenant manager pods - tenant-manager-# fails to initialize.
prelude tenant-manager-0 0/1 Init:0/2 0 The tenant-manager-configure pod shows a status of Error.
prelude tenant-manager-configure-#### 0/1 Error 0
Logs from the tenant-manager-configure pod show the following:
YYYY-MM-DD HH:MM:SS,### | INFO | main | c.v.v.u.l.UpgradeAgent | Examining database at URL: jdbc:postgresql://vcfapostgres.prelude.svc.cluster.local:5432/tenantmanager?socketTimeout=90&ssl=verify-full&sslrootcert=/vmsp-platform-trust/bundle.pem | %PARSER_ERROR[x]
YYYY-MM-DD HH:MM:SS,### | ERROR | main | c.v.v.u.l.UpgradeAgent | A previous attempt to upgrade the database was incomplete. Please restore your database from a backed up copy and try again. | %PARSER_ERROR[x]VCF Automation 9.0.x
user_session and session_role tables grow excessively large over time. During an upgrade to VCF Automation 9.1, this table inflation exceeds internal thresholds and causes the Tenant Manager database schema migration to time out, fail, or prevent the pod from initializing.A fix for the scheduler is included in the future release. For assistance with rollback and database truncation, contact Broadcom Support.
Workaround:
If you have not yet attempted the upgrade or need to recover and retry, perform the following steps prior to triggering the upgrade to VCF Automation 9.1:
select count(*) from user_session;
select count(*) from session_role;TRUNCATE user_session,session_role;Attempting an upgrade while tables are inflated will result in downtime and an inaccessible VCFA management console, requiring a database restore to recover. Always ensure valid database backups exist prior to starting system upgrades.
Reference TechDocs: Component Backup and Restore of VMware Cloud Foundation