When attempting to source environment variables or start services, the following error is received: ERROR - Cannot set the effective uid to 0. Please make sure "$AUTOSYS_CSUTILS/bin/assrvc" has Set-Uid permissions
The assrvc utility requires root privileges to function correctly. This error occurs if either of the following conditions is true:
assrvc file is owned by a non-root user (e.g., the autosys user). On Linux, the Set-UID bit only grants root access if the file is owned by root.$AUTOSYS_CSUTILS/bin/ resides (often /opt) is mounted with the nosuid option, which prevents the execution of Set-UID binaries./opt with the appropriate mount point if different)nosuid, the filesystem must be remounted without this restriction. Consult your System Administrator to update /etc/fstab and remount the volume:Re-run the original operation. The command should now execute without the effective UID error
To speak with a customer representative or a Support Engineer see Contact Support. Scroll to the bottom of the page and click on the respective region.