エラー: NSX VLAN バックセグメントに接続された VM が自身のゲートウェイに ping できません
search cancel

エラー: NSX VLAN バックセグメントに接続された VM が自身のゲートウェイに ping できません

book

Article ID: 450026

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項:これは英文の記事「Error: VM connected to NSX VLAN backed segment cannot ping its own gateway」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • VMは、物理スイッチ上のデフォルトゲートウェイを介して、NSX VLANで保護されたセグメントに接続されます。
  • 特定のVLAN(例:DMZ-37)上のすべての仮想マシンは、ユーザーからアクセスできません。
  • 仮想マシンは同じサブネット上では相互に通信できますが、自身のデフォルトゲートウェイにpingすることはできません。
  • パケットキャプチャでは、VMスイッチポートとESXiホストのアップリンクからトラフィックが送信されていることは確認できるが、戻りトラフィックは受信されていない。

 

Environment

  • VMware NSX 4.x
  • VMware vSphere ESXi 8.0 / 7.0
  • 物理スイッチ(アンダーレイ)

Cause

仮想マシンのトラフィックはVMwareネットワークスタックを正常に通過し、物理アップリンクから出力されますが、上流の物理ネットワークでパケットがドロップされたり、ホストへの戻りトラフィックのルーティングに失敗したりします。
これは多くの場合、物理トランクポートでVLANが明示的に許可されていないか、MACラーニングの問題が原因です。

Resolution

  1. クライアントVMからデフォルトゲートウェイに向けてpingを実行します。
  2. VMware NSX のパケットキャプチャのトラブルシューティング手順に従って、クライアント VM のスイッチ ポートと ESXi ホストのアップリンクでパケットをキャプチャします。
  3. パケットがホストのアップリンクから送信されているにもかかわらず、ARP応答を受信して​​いないかどうかを確認してください。
  4. トラフィックがESXiホストから送信されている場合は、ネットワークチームに以下の対応を依頼してください。
  • ESXiホストに接続されている物理スイッチのトランクポートで、特定のVLANが明示的に許可されていることを確認してください。
  • 物理スイッチのMACアドレステーブルを確認し、影響を受ける仮想マシンの仮想MACアドレスが正しく学習されていることを確認してください。
  • ホストからゲートウェイへのARPリクエストを追跡して、パケットがドロップされるポイントを特定します。

さらに詳しいサポートが必要な場合は、Broadcomサポートにお問い合わせください。