Error: "Failed to configure VC to send logs" when enabling Log Collection for vCenter in VCF Operations 9.1
search cancel

Error: "Failed to configure VC to send logs" when enabling Log Collection for vCenter in VCF Operations 9.1

book

Article ID: 450005

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • When activating Log Collection in VCF Operations for vCenter, the collection fails with the below error seen in Administration -> Configurations -> Log Collection -> Log Sources 
    Failed to configure VC to send logs. The collector attempts to configure log collection every 5 minutes
  • Log ingestion is verified as working in the "Explore Logs" section.
  • Deactivating and reactivating the integration does not resolve the issue
  • Logs show: (under service-logs/ops-logs/console.log) 
    2026-06-29T15:40:39.431432623Z stdout F 2026-06-29T15:40:39.431Z ERROR ops-logs 1 [logs@4413 instance="log-processor-1" threadID="pool-34446-thread-8" file="vsphere.service.VimVsphereConfigurer" line="111"] Exception while consuming connection: Client received SOAP Fault from server: Permission to perform this operation was denied. Please see the server log to find more detail regarding exact cause of the failure.
    2026-06-29T15:40:39.431470871Z stdout F com.sun.xml.ws.fault.ServerSOAPFaultException: Client received SOAP Fault from server: Permission to perform this operation was denied. Please see the server log to find more detail regarding exact cause of the failure.
    2026-06-29T15:40:39.431475362Z stdout F at com.sun.xml.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:158) ~[jaxws-rt-4.0.3.jar!/:4.0.3]

Environment

  • VMware Operations 9.1
  • Log Management 9.1
  • vCenter Server 9.x

Cause

Missing permissions on the vCenter user used for collection in VCF Operations prevent the management service from validating the configuration state.

Resolution

To resolve the failure, assign the following privileges to the vCenter service account:

  1. Ensure the vCenter service account has the required "Syslog configuration on ESX hosts" privilege detailed in the documentation
  2.  Update the account permissions to include CertificatesManage certificates