HCX fleet appliances (IX/NE) are stuck in redeploying on vCenter
search cancel

HCX fleet appliances (IX/NE) are stuck in redeploying on vCenter

book

Article ID: 449990

calendar_today

Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

  • The fleet appliance shows in powered off state with suffix "redeploying" in vCenter VM inventory, however the actual fleet appliance VM shows UP and healthy in vCenter.
  • The above behavior is caused by failed redeployment workflow. See below snippet as reference in vCenter GUI https://<vCenter-FQDN> 

Environment

VMware HCX 

Cause

  1. During the IX/NE appliance redeployment or an upgrade, HCX attempts to build a brand-new fleet appliance, configure it, and establish tunnels before it switches the traffic over and deletes the old appliance.
  2. If the deployment of the new appliance fails mid-process, HCX aborts the deployment of the new appliances. Therefore, the original appliances are left completely untouched, and the newly deployed appliance stay in an unconfigured powered-off state.

Resolution

  • Login to the vCenter GUI via https://<vCenter-FQDN>
  • Verify the MAC Address of the existing NE/IX appliance that is in-use powered state.
  • Also, verify the MAC address of VM with suffix redeploying.
  • Login to HCX manager CLI using admin account. Type the following commands
    • ccli
    • list
    • go [Fleet Appliance]
    • show network address
    • Make a note of the MAC address of vNic_X

If the "show network address" output of the active Fleet Appliance matches the MAC address of the powered-on Fleet Appliance VM within vCenter, you may proceed with removing the VM that contains the "re-deploying" suffix by referring to the document here Remove VMs or VM Templates from vCenter or from the Datastore

Additional Information

Ensure that you first remove/unregister the VM before deleting it. Remove VMs or VM Templates from vCenter or from the Datastore