Attempts to remove ESXi hosts thru SDDC manager immediately fails with a message of "Failed to get workflow detail information. Task with ID ########-####-####-####-############ not found". Attempts to remove the hosts again will generate the same error with different Task ID.
Looking at the VxRail host menu (vCenter -> Configure -> VxRail) the Cluster Hosts shows a message of "The VxRail Manager system information is not found."
SDDC Manager 5.x
VCF on VxRail
Certificate mismatch between vCenter and VxRail Manager
Contact Dell technical support for assistance to update vCenter cert for the VxRail Manager