Error accessing backups or mounting NFS share in VMware Cloud Director VAMI
search cancel

Error accessing backups or mounting NFS share in VMware Cloud Director VAMI

book

Article ID: 449909

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • In VMware Cloud Director, accessing the VMware Cloud Director Appliance Management Interface (VAMI) backup page displays the following error:: 'There was an error getting the list of backups: There is no nfs share currently mounted. You must first mount the nfs share before viewing and creating backups'
  • Additionally, when attempting to configure NFS on a newly deployed standby cell, the configuration fails with the following error:: 'Backend validation of NFS mount failed with: Unable to create tmp directory for use by this script: /opt/vmware/vcloud-director/data/nfs-test'

Environment

  • VMware Cloud Director 10.6.x

Cause

This issue occurs when an underlying NFS storage, network, or permissions issue prevents VMware Cloud Director from communicating with, mounting, or writing to the designated NFS share.

Resolution

To resolve this issue, perform the following troubleshooting steps:

  1. Verify that the target NFS storage server is active and accessible over the network from the VMware Cloud Director cell node.

  2. Confirm that export permissions on the NFS server allow the cell node read and write access to create temporary directories on the mount path: Requirements on the NFS server configuration.

  3. Contact your storage administrator or vendor to investigate and resolve the permissions or accessibility issues on the NFS storage side.

Additional Information

For more information, please refer to KB: Cloud Director requirements when using NFS for the transfer server storage