SPS Exceptions reported when trying to access any tab in the Proxy UI
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SPS Exceptions reported when trying to access any tab in the Proxy UI

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Article ID: 4499

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

We are seeing SPS Exceptions when trying to access any of the  tabs in the Proxy UI. The Proxy UI is protected by the Basic Auth Scheme

 

Secure Proxy Server - Error Report

Error Details

Request URI

: /proxyui/spsadminuimain.jsf;jsessionid=C0 [...omitted for brevity...] F2

Error Type

: SPS Exception

Error Code

: WebAgentException

Message

: Web agent has thrown error. More details in SPS logs.

 

Environment

SPS Version: 12.52

Cause

Sps_trace.log:

[10/31/2016][15:51:57][18336][53091184][25a37615-192df38c-35e1ed52-dc950e9d-a6423e52-8d6][CSmHttpPlugin::ProcessCredentials][Missing required cookies, exiting.]

 

The requests were missing cookies.

 

Resolution

You have an ACO parameter called 'requirecookies=yes'. You can change this to 'requirecookies=no'. Recycle the Web Agent and then try the same transaction again. This should solve the issue.