If an upgrading VCF customer to 9.1 has a VCF Operations that reports IPs for its nodes instead of FQDN addresses, then the workflow step of VCF Management components deployment will fail in the beginning with a pre-validation error code: BROWNFIELD_VCF_OPERATIONS_NODE_FQDN_VALIDATION. This prevents deployment of the VCF Management 9.1 components
VCF Operations 9.1.0.0
SDDC Manager 9.1.0.0
The cause is that VCF Operations API for reporting its cluster configuration returns IP addresses instead of FQDN addresses for the master node and all remaining nodes from the cluster.
Change the VCF Operations to report FQDNs instead of IP. Follow the steps in KB, "Node Address in Cluster Management shows a different format than the rest of the cluster"