Cannot upgrade to VCF 9.1 when VCF Operations is registered with IP instead of FQDN
search cancel

Cannot upgrade to VCF 9.1 when VCF Operations is registered with IP instead of FQDN

book

Article ID: 449892

calendar_today

Updated On:

Products

VCF Operations VMware SDDC Manager / VCF Installer VMware Cloud Foundation

Issue/Introduction

If an upgrading VCF customer to 9.1 has a VCF Operations that reports IPs for its nodes instead of FQDN addresses, then the workflow step of VCF Management components deployment will fail in the beginning with a pre-validation error code: BROWNFIELD_VCF_OPERATIONS_NODE_FQDN_VALIDATION. This prevents deployment of the VCF Management 9.1 components 

Environment

VCF Operations 9.1.0.0
SDDC Manager 9.1.0.0

Cause

The cause is that VCF Operations API for reporting its cluster configuration returns IP addresses instead of FQDN addresses for the master node and all remaining nodes from the cluster.

Resolution

Change the VCF Operations to report FQDNs instead of IP. Follow the steps in KB, "Node Address in Cluster Management shows a different format than the rest of the cluster"