免責事項: これは英文の記事「Reload the default certificate in Aria Operations」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
この記事では、Aria Operations (vRealize Operations) でカスタム証明書をアップロードした後に問題が発生した場合、またはカスタム証明書が期限切れになった場合に、デフォルトの Web 証明書に初期化する手順を説明します。
管理 UI からカスタム Web 証明書をアップロードされた後、以下の問題が 1 つ以上発生する。
管理 UI または 製品 UI にアクセスできなくなる。
製品 UI が 「Analytics を待機しています」 というエラーメッセージを報告する。
管理 UI で1つ以上のノードが 「Inaccessible」 として報告される。
Aria Operations クラスタがノードをオフライン状態として 「オフライン化」と表示し、ノードをオフラインまたはオンラインにするためのボタンがグレーアウトしている。
最近のリリースでは、新しい証明書をインストールする前にクラスターがオフラインである必要があります。
/var/log/apache2/error.log が以下のエラーを報告する:[error] Unable to configure RSA server private key SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Aria Operations のアップグレードは、Web証明書の有効期限を確認する際に「アップロードに失敗しました。」というエラーが発生し、アップグレードが完了しません。
インストール中に証明書のアップロードがエラーになり、信頼関係が失われます。LCM 経由で証明書を更新することができなくなり、Aria インスタンスの Web ページにもアクセスできなくなります。
VMware vRealize Operations 8.x
VMware Aria Operations 8.12 以降
デフォルト証明書に初期化するには、以下の手順を実行します。
SSH またはコンソール経由で root としてプライマリ ノードにログインします。コンソールでは ENTER を押してログインします。
デフォルト証明書を初期化するために以下のコマンドを発行します。
unset -f pathappend pathprepend pathremove
$VMWARE_PYTHON_BIN /usr/lib/vmware-casa/bin/activate_web_certificate.py DEFAULT
$VMWARE_PYTHON_BIN /usr/lib/vmware-vcopssuite/utilities/bin/restartHttpd.pyCloud Proxies を除く、Aria Operations クラスタ内のすべてのノードで手順 1 ~ 2 を繰り返します。
unset コマンドは、6.x/7.x から 8.x への移行に伴う python バージョンの違いにより、環境変数に関連するエラーメッセージを回避することができます。
手順 2 の 2 番目のコマンドで DEFAULT および CUSTOM オプションを使用することで、デフォルト証明書とカスタム証明書を切り替えることが可能です。CUSTOM オプションを使用するときはカスタム証明書の期限が切れておらず、トラブルシューティングの目的でカスタム内部証明書とデフォルト内部証明書を切り替える必要がある場合のみにしてください。
手順を実行した後でも 製品 UI または 管理 UI にアクセスできない場合は、サポートリクエストを開いてください。
サポートリクエストを開くための情報は、Creating and managing Broadcom support cases を参照してください。
Aria Operations 用の証明書の作成に関する情報は、Configure a Certificate For Use With VMware Aria Operations を参照してください。