免責事項: これは英文の記事「vCenter Server not visible in Enhanced Linked Mode inventory due to expired Machine SSL certificate」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
vmware-certificatemanagement, vmware-vpxd-svcs, vmware-topologysvc, vmware-vsan-health, vmware-hvc, vmware-sps, and vstats 1 台以上の vCenter Server システムに接続できませんでした: https://<vCenter_fqdn>:443/sdk
/var/log/vmware/vmon/vmon.log に次のエラーが記録されます。File "/usr/lib/python3.7/ssl.py", line ##, in do_handshake self._sslobj.do_handshake()ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: certificate has expired (_ssl.c:###)for store in $(/usr/lib/vmware-vmafd/bin/vecs-cli store list | grep -v TRUSTED_ROOT_CRLS); do echo "[*] Store :" $store; /usr/lib/vmware-vmafd/bin/vecs-cli entry list --store $store --text | grep -ie "Alias" -ie "Not After";done; を実行すると、 __MACHINE_CERT エイリアスの Not After が過去の日付であることが示されます。1 つ以上の vCenter Server ノードでマシン SSL 証明書が期限切れの状態となっています。ELM 環境でマシン SSL 証明書の有効期限を超過すると、Lookup Service および vSphere Client はリモートノードでの認証に失敗します。
root として SSH ログインします。service-control --stop --all && service-control --start --all注: 環境でカスタム CA 署名付き証明書が必要な場合、UI へのアクセスが回復した後に vSphere Client UI ([管理] > [証明書の管理]) を使用して新しい CSR を生成し、新しいカスタム CA 証明書をインポートします。「vCenter Machine SSL Certificate Replacement with Custom CA-Signed Certificate via vSphere Client UI」を参照してください。