NSX Edge のデプロイが「The provided network mapping between OVFnetworks and the system network is not supported by any host.」というエラーで失敗します。
search cancel

NSX Edge のデプロイが「The provided network mapping between OVFnetworks and the system network is not supported by any host.」というエラーで失敗します。

book

Article ID: 449853

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項:これは英文の記事「NSX Edge deployment fails with error "The provided network mapping between OVF networks and the system network is not supported by any host."」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • REST API で Edge をデプロイしようとしています。
  • API にはエラーは返却されませんが、 GUI で [システム] > [ファブリック] > [ノード] > [Edge トランスポートノード]  画面を確認すると「展開処理が失敗」と表示されています。
  • 「展開処理が失敗」をクリックすると、「Ovf deploy for vm ########-####-####-####-######## failed on vc ########.##.## : The provided network mapping between OVF networks and the system network is not supported by any host.」というエラーが表示されます。

  • /var/log/proton/nsxapi.log を見るとエラーの直前に次のようなメッセージ出力があり、 最後のリスト内には API のボディの data_network_ids に指定したネットワークが含まれていません。

2026-07-24T08:46:11.039Z  INFO ActivityWorkerPool-1-0 OvfDeploy 5867 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] [2] networks map between cluster [domain-c1011],host [null] and datastore [datastore-23], viz. [[dvportgroup-59, network-19]]
2026-07-27T08:14:27.126Z ERROR ActivityWorkerPool-1-11 OvfDeploy 5867 SYSTEM [nsx@6876 comp="nsx-manager" errorCode="MP40409" level="ERROR" subcomp="manager"] Ovf deploy failed for vm ########-####-####-####-######## failed on vc ########.##.## with createImportSpecResult error The provided network mapping between OVF networks and the system network is not supported by any host.

 

Environment

VMware NSX

Cause

data_network_ids に指定したネットワークが、デプロイ先に指定したクラスタやリソースプールに関連付けられたホストで使用可能なネットワークの一覧に含まれない場合にこのエラーで失敗します。

デプロイ先のクラスタやリソースプールの指定を誤っていることが原因かもしれません。

Resolution

実行した API のリクエストボディにおいて、ネットワークが指定したクラスタやリソースプール内のホストで利用可能であることを確認してください。

可能なら、 GUI でのデプロイを検討してください。GUI の場合は選択したクラスタやリソースプール内のホストで指定可能なネットワークのみが選択肢に表示されるので、このような間違いを防げます。