System > Fabric > Nodes./var/log/search/search-manager.log reveals OpenSearch indexing errors and connection refusals, with symptoms including:2026-07-14T07:36:00.937Z ERROR NSX 8504 [nsx@4413 comp="nsx-manager" errorCode="MP60507" level="ERROR" logger="SearchServiceImpl" reqId="92f2####-9270-####-a840-cde####e7f7b" subcomp="manager" threadName="http-nio-127.0.0.1-7440-exec-24009" username="user\\/* AND resource_type:PolicyEdgeNode"}},{"bool":{}}],"must_not":[{"match":{"_meta.isOverridden":{"query":true}}}],"should":[{"bool":{"must":[{"query_string":{"query":"path.aggregation:\\/*"}}]}},{"bool":{"must":[{"bool":{"must":[{"query_string":{"query":"(!resource_type:(Alarm OR MonitoringEvent OR IDSEvent OR ConsolidatedRealizedStatus OR VirtualMachine OR VirtualNetworkInterface OR GenericPolicyRealizedResource) AND !(_exists_:path))"}}]}}]}}]}}
2026-07-14T07:36:00.940Z ERROR NSX 8504 [nsx@4413 comp="nsx-manager" errorCode="MP60506" level="ERROR" logger="SearchServiceImpl" reqId="92f2####-9270-####-a840-cde####e7f7b" subcomp="manager" threadName="http-nio-127.0.0.1-7440-exec-24009" username="svc-###-nsx"] [QueryExecution: Execution] Exception while searching, query: dsl: null query: NOT path:\/global-infra\/* AND resource_type:PolicyEdgeNode\njava.net.ConnectException: Connect to http://localhost:9200 [localhost/127.0.0.1] failed: Connection refused
2026-07-14T07:36:29.446Z ERROR NSX 8504 [nsx@4413 comp="nsx-manager" errorCode="MP60524" level="ERROR" logger="SearchServiceWatchDog" subcomp="manager" threadName="SearchHealthCheck"] [Search: WatchDog] OpenSearch health status is REDVMware NSX 9.1.0
In the logical migration during the upgrade path from 4.2.x to 9.1.x, the Edge Transport Node (TN) path changes from */edge-transport-node/* to */edge-transport-nodes/*. As part of the NSX 9.1 hitless upgrade design, the first node to be upgraded intentionally skips rebuilding its search index.
Consequently, this first node's search index is left with a stale Edge TN path within the PolicyEdgeCluster Data Transfer Object (DTO). When the UI attempts to perform a join operation between PolicyEdgeCluster and PolicyEdgeTransportNode, the edges with the stale path fail to populate.
The issue is planned to be resolved in upcoming releases.
Workaround
admin user.start search resync all