After an ESXi reboot, hosts with TPM enabled may lose all custom configurations, including IP settings and passwords, reverting to a DHCP state.
VMware ESXi 9.x
This is caused by a failure to save encryption keys during the previous shutdown.
The /tmp ramdisk is 100% full. This prevents the system from writing the /encryption.info file to the bootbank during shutdown/restart.